How to make corners stop sagging to the blocks?

I keep getting burnt by my CPU helping down to the corners, I have ace off and tight/tight.

you can’t


Lol comp

Best thing to do right now is to put deny on offball settings rather than tight. Happens less often but be wary of back door cuts.


Yeah I tried that too, and other comp players know to backdoor cut … hopefully 2k will fix it.

Stay home in the in-game setting has helped a little bit.

1 Like

I’ll try that out but it needs to be fixed regardless. CPU do what they want on court smh.

Haha facts, need Bob Knight on the bench to strike some fear into their virtual souls @tsunamiwaves

1 Like

Make sure adaptive coaching engine is shut off under coaching settings. Otherwise the settings reset to whatever the game situation seemingly calls for.

Only thing that works for me is switching to the players who start pinching in and forcing them back to their man.

Yessir, the worst part is when both dudes on the corners sprint to the blocks like their lives depend on it

You can’t unfortunately. I try stay home, smother/deny, no threes and it doesn’t matter eventually one or both corner defenders will walk right up to the paint.

Yeah. It’s painful. Especially against teams who 5 out you, like Bucks, Nuggets, Hawks.

The settings are broken

Just like when calling a play for a cutter, only to have your center wander into the lane, dragging a defender with him for an easy block

It’s a pain in the ass to try and cover the PNR and then switch to try to cover the corner shooter at the same damn time.

I started using “stay attached” on picks and just cover the corner myself. I would rather give up some twos than threes. :man_shrugging:

1 Like

What will keep my digital men from leaving shooters wide open in the corner?


I always put deny and then no help on the drive

I feel like putting help defense on 0 in the coaching sliders and setting “no help” along with “deny” in defensive settings helps a lot. You may wanna put “tight” instead of deny if they start back cutting tho. Make sure ACE is off too, as it’ll override your manual settings.